Contenu

technologies et sciences des ingénieurs

Recherche simple Vous recherchez ...

espace pédagogique > disciplines du second degré > STI > documentation > didacticiels/tutoriels

didacticiels/tutoriels

Solidworks / Sketchup / SweetHome3D : transferts de fichiers

Clg-documentation.jpg

Voilà des méthodes pour créer vos objets 3D et les récupérer dans vos autres logiciels.




De Solidworks vers Sketchup (version récente de Solidworks) :


  • dans le répertoire d'installation de collada  (typiquement C:Program FilesSolidWorksSW Collada Add-inlangenglish), copier le contenu du répertoire "english" vers un nouveau répertoire "french" que vous créer dans "lang"
  • ouvrez votre fichier à convertir avec Solidworks, allez dans le menu "Outils" puis "Compléments", trouvez le plug-in collada, cochez les 2 cases et cliquez sur ok
  • maintenant en haut à gauche sous l'icône solidworks apparait la barre d'outils collada avec son icône (un engrenage vers un dossier) "export to collada", cliquez dessus et enregistrez votre fichier *.dae (mais vous avez aussi dans le menu "Fichier" une nouvelle option "Save as Collada...")
  • ouvrez sketchup 7.1 (pas antérieur car cela ne fonctionne pas ! ), cliquez sur "fichier" puis "import", sélectionnez le type google earth *.dae , ouvrez votre fichier et enregistrez le en *.skp


De Solidworks vers Sketchup (toute version de Solidworks, grâce à Meshlab) :


  • téléchargez et installez le logiciel libre Meshlab
  • ouvrez votre fichier à convertir avec Solidworks et enregistrez sous le format STL
  • ouvrez ce fichier STL avec Meshlab (menu "File puis "Import Mesh"), vérifiez que "Unify Duplicated Vertices" est coché et répondez OK
  • enregistrez le au format DAE (menu "File" puis "Export Mesh As")
  • ouvrez sketchup 7.1 (pas antérieur car cela ne fonctionne pas ! ), cliquez sur "fichier" puis "import", sélectionnez le type google earth *.dae, ouvrez votre fichier et enregistrez le en *.skp


Depuis SweetHome 3D vers Sketchup (pas de filtre à ma connaissance pour Solidworks) :

c'est assez facile car SweeetHome permet d'exporter tous les fichiers au format OBJ.

ATTENTION : l'exportation de puis SweetHome3D prend un peu de temps, mais l'ouverture dans Sketchup est TRES longue car les éléments sont décomposés, donc nombreux.

Donc la méthode :
  • dans SweetHome3D, dérouler le menu "Vue 3D" pour trouver la commande "Exporter au format OBJ...",
  • choisir le dossier et le nom du fichier de destination,
  • mais pour que Sketchup puisse lire ce type de fichiers, il faut d'abord télécharger le plugin FluidImporter (page de téléchargement) et l'installer,
  • dans Sketchup, utiliser la commande "Importer..." du menu "Fichier", vous avez maintenant la possibilité d'importer les fichiers au format OBJ
  • dans la boîte de dialogue, répondez comme suit :

ATTENTION : l'import est TRES long !

Ne soyez pas étonné des résultats :

Le fichier de départ sous SweetHome3D


Le fichier importé sous Sketchup :
(pensez à éclater le composant pour le nettoyer, notamment supprimer le toit...)




Vers SweetHome 3D (depuis Sketchup ou  Solidworks) :


alors là c'est encore plus facile car SweeetHome permet d'importer tous les fichiers au format DAE (ou en ZIP mais au format Collada, comme lorsque vous téléchargez un modèle depuis la banque d'images 3D de Google), mais il nécessite quelques informations :
  • ouvrez SweetHome 3D (une version récente)
  • dans le menu "Meubles" puis "Importer meuble", cliquer sur "Choisir modèle"
  • sélectionnez votre fichier et dans la panneau suivant déterminez son orientation
  • complétez (ou vérifiez juste) ensuite si besoin les dimensions de votre objet
  • votre nouveau meuble apparaît alors dans la liste des objets utilisables


Téléchargements, cliquez sur les liens ci-dessous :

plug-in pour Solidworks "export collada" *.dae depuis Solidworks Labs

logiciel libre Meshlab

plugin pour Sketchup FluidImporter

 

haut de page

technologies et sciences des ingénieurs - Rectorat de l'Académie de Nantes